Page 1 of 1

#21, The Master Chef mod version 5.0 - 1.9.4 #Compatibility Update

Posted: Sun Aug 28, 2016 4:04 pm
by Kander18
|-----------------------------------------------------------|
| Master Chef 5.0 for 1.9.4: Compatibility update |
|-----------------------------------------------------------|

Version 5 of this mod is now compatible for minecraft version: 1.9.4.
There will be one more update for 1.9.4.

Updated to forge 12.17.0.1976.